Home / Advisories / KLCERT advisories / KLCERT-20-004: Remote Code Execution on TigerVNC version prior to 1.10.1

KLCERT-20-004: Remote Code Execution on TigerVNC version prior to 1.10.1

Kaspersky publishes information on newly identified vulnerabilities in order to raise user awareness of the IT security threats detected. Kaspersky does not make any guarantees in respect of information received from vendors of products in which vulnerabilities have been identified, which is included in the following sections of the advisory: Affected Products, Vendor Mitigation.

KL-IDS KLCERT-20-004
CVE-IDS CVE-2019-15694
Publication date 2020.03.23
Researcher Pavel Cheremushkin, Kaspersky ICS CERT
Description TigerVNC version prior to 1.10.1 is vulnerable to heap buffer overflow, which could be triggered from DecodeManager::decodeRect. Vulnerability occurs due to the signdness error in processing MemOutStream. Exploitation of this vulnerability could potentially result into remote code execution. This attack appear to be exploitable via network connectivity.
Impact Successful exploitation of this vulnerability could allow an attacker to execute arbitrary code.
Severity
CVSS v3 Base Score: 8.8
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H/E:P/RL:O/RC:C
Exploitability Remotely
Difficulty Low
User interaction None
Existence of exploit Unknown
Affected products
Affected products TigerVNC version prior to 1.10.1
Mitigation
Vendor mitigation Update current version of TigerVNC.
Timeline Nov 2019 – Vulnerabilities reported
Dec 2019 – Vendor releases patch
Dec 2019 – Advisory published