23 March 2020

KLCERT-20-003: Remote Code Execution on Emerson OpenEnterprise SCADA Server version 2.83 and all versions of OpenEnterprise 3.1 through 3.3.3

Vendor

Emerson

Timeline

Timeline

  • Kaspersky ICS CERT advisory published

    February 2020

  • Vendor advisory published

    February 2020

  • Patched

    February 2020

  • Vulnerability reported

    December 2019

Description

A Heap-based Buffer Overflow was found in Emerson OpenEnterprise SCADA Server version 2.83 (if Modbus or ROC Interfaces have been installed and are in use) and all versions of OpenEnterprise 3.1 through 3.3.3, where a specially crafted script could execute code on the OpenEnterprise Server.

Exploitability

Remotely

Attack complexity

Low

User interaction

None

Impact

Successful exploitation of this vulnerability could allow an attacker to execute arbitrary code.

Existence of exploit

Unknown

Affected products

OpenEnterprise SCADA Server version 2.83
OpenEnterprise versions 3.1 through 3.3.3

Mitigation

Vendor mitigation

Emerson recommends all users upgrade to OpenEnterprise 3.3, Service Pack 4 (3.3.4), to resolve this issue. OpenEnterprise Service Packs are available to users with access to the Emerson SupportNet system (login required). Details will be found in the downloads area.

Kaspersky publishes information on newly identified vulnerabilities in order to raise user awareness of the IT security threats detected. Kaspersky does not make any guarantees in respect of information received from vendors of products in which vulnerabilities have been identified, which is included in the following sections of the advisory: Affected Products, Vendor Mitigation.

Timeline

  • Kaspersky ICS CERT advisory published

    February 2020

  • Vendor advisory published

    February 2020

  • Patched

    February 2020

  • Vulnerability reported

    December 2019