Home / Advisories / KLCERT advisories / KLCERT-18-025: General Electric Proficy GDS XML eXternal Entity (XXE)

KLCERT-18-025: General Electric Proficy GDS XML eXternal Entity (XXE)

Kaspersky Lab publishes information on newly identified vulnerabilities in order to raise user awareness of the IT security threats detected. Kaspersky Lab does not make any guarantees in respect of information received from vendors of products in which vulnerabilities have been identified, which is included in the following sections of the advisory: Affected Products, Vendor Mitigation.

KL-IDS KLCERT-18-025
CVE-IDS CVE-2018-15362
Publication date 2018.12.07
Researcher Sergey Temnikov, Kaspersky Lab ICS CERT
Description An XXE injection vulnerability leads to path traversal inside the Proficy server. An attacker may be able to initiate an OPC UA session and retrieve an arbitrary file from the target system.
Impact Successful exploitation of this vulnerability could allow an attacker to initiate an OPC UA session and retrieve an arbitrary file.
Severity
CVSS v3 Base Score: 8.2
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H
Exploitability Remotely
Difficulty Low
User interaction None
Existence of exploit Unknown
Affected products
Affected products
  • Cimplicity 9.0 R2,
  • Cimplicity 9.5, and
  • Cimplicity 10.0
Mitigation
Vendor mitigation GE recommends users update to Version 2.1 or newer. The fixed version is available at the following link: https://ge-ip.flexnetoperations.com/control/geip/download?element=10544807 (Login required)
Timeline Jan 2017 – The vulnerability is reported
Jan 2018 – The vendor has stopped replying regarding this issue. The problem is escalated to US ICS-CERT
Dec 2018 – The vendor releases a patch
Dec 2018 – An advisory is published