Home / Advisories / KLCERT advisories / KLCERT-19-010: UltraVNC Stack-based Buffer Overflow

KLCERT-19-010: UltraVNC Stack-based Buffer Overflow

Kaspersky Lab publishes information on newly identified vulnerabilities in order to raise user awareness of the IT security threats detected. Kaspersky Lab does not make any guarantees in respect of information received from vendors of products in which vulnerabilities have been identified, which is included in the following sections of the advisory: Affected Products, Vendor Mitigation.

KL-IDS KLCERT-19-010
CVE-IDS CVE-2019-8263
Publication date 2019.03.01
Researcher Pavel Cheremushkin, Kaspersky Lab ICS CERT
Description UltraVNC revision 1205 has stack-based buffer overflow vulnerability in VNC client code inside ShowConnInfo routine, which leads to a denial of service (DoS) condition. This attack appear to be exploitable via network connectivity. User interaction is required to trigger this vulnerability. This vulnerability has been fixed in revision 1206.
Impact Successful exploitation of this vulnerability could allow an attacker to cause denial of service.
Severity
CVSS v3 Base Score: 7.5
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Exploitability Remotely
Difficulty Low
User interaction None
Existence of exploit Unknown
Affected products
Affected products UltraVNC before 1.2.2.3
Mitigation
Vendor mitigation Update UltraVNC to revision 1206.
Timeline Jan 2019 – Vulnerabilities reported
Feb 2019 – Vendor releases patch
Mar 2019 – Advisory published