Home / Advisories / KLCERT advisories / KLCERT-20-011: Inadequate Encryption Strength in Emerson OpenEnterprise SCADA before 3.3.4

KLCERT-20-011: Inadequate Encryption Strength in Emerson OpenEnterprise SCADA before 3.3.4

Kaspersky publishes information on newly identified vulnerabilities in order to raise user awareness of the IT security threats detected. Kaspersky does not make any guarantees in respect of information received from vendors of products in which vulnerabilities have been identified, which is included in the following sections of the advisory: Affected Products, Vendor Mitigation.

KL-IDS KLCERT-20-011
CVE-IDS CVE-2020-10636
Publication date 2020.05.20
Researcher Roman Lozko, Kaspersky ICS CERT
Description Inadequate Encryption Strength in Emerson OpenEnterprise SCADA versions before 3.3.4.
Impact Inadequate encryption may allow the passwords for OpenEnterprise user accounts to be obtained.
Severity
CVSS v3 Base Score: 6.5
Vector CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
Exploitability Local
Difficulty Low
User interaction None
Existence of exploit PoC
Affected products
Affected products Emerson OpenEnterprise SCADA versions before 3.3.4.
Mitigation
Vendor mitigation Emerson recommends all users upgrade your OpenEnterprise system to OpenEnterprise 3.3.5 (OpenEnterprise 3.3 Service Pack 5). All computers with OpenEnterprise installations must be upgraded.
Timeline Dec 2019 – Vulnerabilities reported
May 2020 – Vendor releases patch
May 2020 – Advisory published