17 August 2018

KLCERT-18-008: Kraftway-24F2XG Router Denial of Service

Researcher

Alexander Nochvay

Timeline

Timeline

  • Kaspersky ICS CERT advisory published

    17 August 2018

  • Vulnerability patched

    August 2018

  • Vulnerability reported

    December 2017

Description

A remote attacker with low privileges can cause denial of service.

Exploitability

Remotely

Attack complexity

Low

User interaction

None

Impact

A remote attacker can cause denial of service of the device.

Existence of exploit

Unknown

Affected products

Kraftway-24F2XG Router firmware 3.5.30.1118

Mitigation

Vendor mitigation

Update firmware: ver 3.5.47-315-gef7 and higher.

Kaspersky Lab publishes information on newly identified vulnerabilities in order to raise user awareness of the IT security threats detected. Kaspersky Lab does not make any guarantees in respect of information received from vendors of products in which vulnerabilities have been identified, which is included in the following sections of the advisory: Affected Products, Vendor Mitigation.

Timeline

  • Kaspersky ICS CERT advisory published

    17 August 2018

  • Vulnerability patched

    August 2018

  • Vulnerability reported

    December 2017